All customers are recommended to apply GI and DB patches.
Summary
After disks are offlined and later onlined, ASM Staleness Registry may get corrupted, which in turn may cause long resync times or potential user data inconsistency.
Symptoms
-
WARNING: disk number check failed for Staleness Registry
messages in the alert log; - full disk resync taking long time;
- possibility of user data getting logically inconsistent, e.g. "lost write" reported
Affected Products
FlashGrid Cluster on AWS/Azure/GCP
FlashGrid Storage Fabric (on-premises)
Affected Versions
GI and DB Oracle homes without Database 19.27 (April 2025) Release Update or patch 37534744.
Root Cause
Oracle bugs:
- Bug 36349207: [ASM] Read Resulted In Corrupt Block In Staleness Registry During Disk Failure Test
- Bug 37534744: [ASM] Slow ASM Resync while Onlining the Disks of the 2nd Cell being Patched (the fix for this bug supersedes the fix under bug 36349207)
Resolution
Apply Database 19.27 (April 2025) Release Update that includes patch 37534744.
OR
Apply patch 37534744 if it is available for your version.
The patch, either the Release Update or one-off, should be applied to GI and all DB Oracle homes.